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Abstract

With the current version of LyX and with the preview-style installed
in the ITEX-System, the graph drawing package ¥Pic can now be con-
veniently used inside LyX. Diagrams can be edited and displayed inside
the main IyX editing window. Here, we shall describe how to use the
\xymatrix command from xypic inside LyX in order to draw, to edit and
to preview diagrams as typically used in category theory, algebra, and
related fields.
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1 Introduction

The xypic-package has long served as a convenient tool for easily constructing
graphs and diagrams in EXTEX. Unfortunately, its use in IyX had long been
restricted to the infamous ERT-boxes, meaning that the IyX editor could only
display the IXTEX-source and not the finished diagram. The new preview-style
of BTEX which is part of the AUCTEX project[4], finally enables the editing and
displaying of xypic-diagrams, constructed, displayed and interactively edited
inside LyX.
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Editing ~:-Pic figures in LyX

Below you see an -Pic diagram inside LyX being edited and to the right

you gee how the diagram appears when the cursor leaves the editing area.
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In this note, we describe how Xy-pic can be used from inside LyX, how
diagrams can be created and edited. We have tested the following using LyX
version 1.3.7, running under WindowsXP.

There are two modes of operations: For a start, and for some first tests, it
may be easiest to first enter the Xy-Pic code inside the LyX-window, select it
all and convert it to a graphical representation by pressing Ctrl-m or Ctrl-M. If
you use Xy-Pic more frequently, or if you want to modify your initial figure, you
will want to assemble and modify your figures using LyX’s math editor. This is
shown in blue in the above figure: Once the cursor is moved over a diagram, this
is displayed as an array of nodes and arrow-commands. These can be changed
interactively. When the cursor leaves the editing area, the diagram reappears.

In the first two sections of this documentation, we explain how to use LyX
in the first mentioned mode and introduces all Xy-Pic features that might be of
use for drawing commutative diagrams, graphs or automata. Section 3 explains
how to use the Xy-Pic commands inside a math-editing area.

It is not our intention to write another introduction to Xy-Pic, rather our
motivation is to give an introduction how the most important commands work
inside LyX, since the keystrokes as explained in the Xy-Pic manual[?] will not
always function correctly inside LyX.

2 Preparation

The following requires that the KWTEX-packages xypic and preview are installed
in the IWTEX system. They are available from CTAN, see at [2], resp. at [3].



After freshly installing them, it may be necessary, to run Edit> Reconfigure from
the main IyX menu. The steps to a first diagram output in IyX are then:

1. Activate and test preview

(a) Open LyX, choose Edit>Preferences>Look and Feel> Graphics and
place a check-mark at Instant Preview.

(b) Test, if instant-preview works by opening a IyX-document and
entering any math-formula, e.g. a + b = c.

(c) Move the cursor out of the formula, and watch it change its appear-
ance to look just like in the finished dvi- or postscript document.

2. Activate and test xypic

(a) Choose LayoutDocument>Preamble and type
\usepackage [all]l{xy}.

(b) Inside your LyX-Document, enter the text
\xymatrix{A \ar([r] & B}.

(c) Select the whole text and choose Insert>Math > Display Formula, or
use the corresponding keyboard shortcut Ctrl-M.

(d) Move the mouse cursor out of the editing box and wait for a split
second to see an arrow appear: A —— B .

3 Commutative diagrams

The following diagram, which is taken from the documentation of X~Pic[?] by
its creator Kristoffer H. Rose, will provide an example for many of the features
available with that package. Its source code is:

\xymatrix{
U \ar@/_{1pc}/[ddr] _\psi\ar@/~{1ipc}/[drr] “\varphi
\ar@{.>}[dr] |-{(x,y) }\\
& X \times_Z Y \ar[d]"q \ar[rl_p & X \ar[d]_f\\
& Y \ar[rl-g & Z1%

Again, to turn this code into a graphical output, select it all at once starting
from the \xymatrix{ ... up to the closing brace ... } and turn it into display-
math as explained above. A moment after the cursor leaves the math-area, you
should see the diagram in its full graphical glory as shown below.




3.1 The matrix layout of diagrams

xymatrix uses a matrix to define the layout of the vertices of a diagram. For
the above example, we need a 3 x 3-matrix of which 5 entries are used for the
vertices U, X xzY, X, Y, Z, the other positions remaining empty. In this case,
the following matrix determines the layout:

\xymatrix{
U AR
& X\times_Z Y & X \\
&Y & Z }

The pattern should be familiar from KTEX: We see three rows, each row being
terminated by the end-of-line-marker \\ . Each line consists of entries, separated
by the ampersand &.

3.2 Arrows

Having entered the vertices, we add arrows between them. The basic xypic-
command to produce an arrow is \ar , it is entered into the cell of the matrix
where the arrow is to start. The target of the arrow is defined by direction
commands u (up) d (down) 1 (left), or r (right). These can be combined to
a path and enclosed in square brackets. As an example, the arrows from the
vertex U in the upper left corner down and right to the vertices X xz Y, Y,
and X are, respectively, defined as \ar [dr], \ar [ddr] and \ar [drr]. Thus the
above diagram with all arrows added becomes:

\xymatrix{
U \ar[ddr] \ar[drr] \ar([dr]\\
& X \times_Z Y \ar[d] \ar[rl& X \ar[d]\\
& Y \ar([r] & Z }

U
x
Xx,Y —2x
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Y A
3.3 Labels

Labels are attached to arrows by affixing them as upper or lower indices to the
\ar-command. Thus, \ar [drr] ~\varphi defines an arrow going one cell down,
two to the right and having the label ¢ attached above. To attach a label below
the arrow, make it a lower index as in \ar[ddr]_\psi. This explanation is
correct only for arrows pointing to the right. More precisely, imagine looking
along the arrow in the direction it is pointing. Then an upper index places
a label to the left and a lower index places it to the right. Consequently, an
arrow pointing from right to left, such as \ar[1] “\alpha_\beta will have label



a below and label 8 above the arrow, i.e. % - Using the character | instead

of ~ or _ | it is even possible to place the label right onto the arrow, obscuring
part of its shaft.

Normally, a label is placed halfway between an arrow’s start and target
objects. In the first diagram, the central arrow starting in U has the label (z,y)
in the middle of the arrow’s shaft, rather than in the middle between the two
objects it connects. This is achieved by prefixing the label with a minus sign,

here: \ar[dr] |-{(x,y)}.

\xymatrix{
U \ar[ddr] _\psi \ar[drr]~\varphilar[dr]|-{(x,y) }\\
& X \times_Z Y \ar[d]~q \ar[r]_p& X \ar[d]_f\\
& Y\ar[rl g & Z }

Y ———Z

Xy-pic normally permits labels to be shifted towards the tip or towards the
end of an arrow by prefixing the label with a ratio, such as e.g. (.3). In
Iy X this works only for labels which are placed on top of the arrow, such as
\ar[r] | (0.3){\phi}. The form\ar[r]|-{(x,y)} used above guarantees that
the label is placed at the midpoint of the arrow rather than at the midpoint
between the nodes connected by the arrow.

For labels placed to the left or to the right of the arrow this does not work.
The corresponding Xy-pic code such as e.g. \ar[r]~(.3)p is not correctly in-
terpreted by LyX’s math editor. A workaround is suggested in the last section
of this note.

3.4 Arrow modification

Modification of the design, the form or the positioning of arrows are introduced
by the @-character. This is followed by a pair of matching brackets, where the
form of the bracket pair, { } or < >or / / indicates, whether we want to modify
the design, the shift or the curvature of the arrow. Various modifactions can be
applied to an arrow at the same time.

3.4.1 Arrow design

Various designs such as solid, dotted, dashed or double are possible for the shaft of
an arrow. These can be combined with various ends and various tips. In general,
the design of an arrow is described by following the command \ar immediately
by an @-sign and a pair of braces {. ..} containing characters describing the end,
the shaft and the tip of the arrow. These characters are chosen to give some
form of ASCII-rendering of the real thing. For instance \ar@{>..>>} produces
an arrow with split end, a dotted shaft and double head. A number of other
arrow designs is given in the table below. Note that the ends of embedding



arrows A———= B are described by raising or lowering opening parentheses,
such as in \ar@{~ (->}[r].

| Result [ Source code in IyX |

. \ar
s \are{-->}
. \areq{..>}
s \are{">}
. \ar@{->>}
I \ar@{-->>}
N \ar@e{>->>}
— \ar@{_(->}
o \ar@{~ (>3}
— \ar@{ |-}

Following the @-character by either a 2, 3, _jor a ", we can produce arrows with
double, triple shaft or arrows showing only the lower or upper half of their tips
and ends. Arrows need not have tips nor ends, as the last example shows :

| Result [ Source code for IyX |

— \ar@2

—_— \ar@3

- \ar@_{->3}

o \ar@~{->3}
N \ar@~{>>->>}

- \are{"<-_>}

— - | \are2{--} \

3.4.2 Designing your own arrows

Within certain limits there is even a way to design your own arrows. Using some

the characters ><|ox+/() [ one can even design one’s own arrow tips using the

\newdir command in the preample. For explanations, we refer to the ¥manual,

from which we take the example:
\newdir{|>}{!/4.5pt/@{|}*:(1,-.2)0 " {>}*: (1,+.2)e_{>}}.

This defines a new arrow tip, referred to as |> in \ar@{-|>}[r] and which

displays correctly in LyX as:

A—>1B

3.5 Arrow positioning

Arrows are shifted sideways with the modifier @<... > where the ellipsis is re-
placed by a positive or negative measure. For instance, to design a pair of
mutually opposing arrows between two nodes, we shift them to see them apart.
Note that the direction of the shift (positive) is to the left if one looks along the
arrow. Thus



\[\xymatrix{\circ \ar@<lex>[r]& \circ \ar@<lex>[1]}\]

produces

- 5
O o]
-~

3.5.1 Inline or centered diagrams

Arrows and diagrams can be used inline, as this one: o __~ o. For this
they should be placed inside an inline math-environment $ ...$ or \(...\). To
center a diagram, put it inside display-math parentheses \[ and \]. Diagrams
constructed inline can later be centered, or, conversely, centered diagrams can
be changed to inline formulas with Edit>Math > Alignment.

3.6 Bending arrows

There are two simple methods to make arrows bend. The first is giving an
explicit value by which the midpoint of the arrow’s shaft is raised or depressed,
the other is by forcing the arrow to leave its origin in a prescribed compass
direction and to make him enter the target at another direction. The necessary
bending of the arrow is determined automatically. We describe both methods.

3.6.1 Raising the shaft

For bending arrows we use the modifier @/.../ . The ellipsis stands for a TEX-
measure which needs to be entered as a lower or upper index. Whereas in xypic,
we could simply write, e.g. \ar@/_1pc/ for an arrow bending 1pc downwards,
this cannot directly be done in Iy/X. It is necessary, to enclose the measure in a
pair of braces, such as e.g. \ar@/_{1pc}/. As an example, here are two opposing
arrows between A and B, each bending by .5 pica, given by the following source
code:

\ [\xymatrix{A \ar@/_{.5pc}/[r] & B \ar@/_{.5pc}/[11}\]

PN

A B

ST

3.6.2 Specifying exit- and entrance directions.

An alternative for making arrows bend is by specifying their compass direction
as they are leaving their source and their direction from which they enter their
target. Instead of north, north-east, east, etc., the directions are named u, ur,
r,dr, d, d1, 1, ul, standing for up, up-right, right, down-right, etc.. A direction
is specified as @(out,in) where out stands for the direction the first object is left
and in stands for the direction from which the target is entered. As an example,
we show some bending arrows and a loop, which arises when we do not specify
a target for an arrow, just its incoming and outgoing direction:

A B C
|

\ )

Eé«—/



\[\xymatrix{A \ar@(dr,dl) [r]\ar@(dr,dl) [rr]
&B\ar@(d,r) [d1] &C \\
E \ar@(ul,ur)}\]

3.7 Modifying vertices

The above example is reminiscent of an automata diagram, except that in such
a diagram states would be enclosed in small circles, with double circles denoting
final states.

3.7.1 Framing objects

With Xy-Pic, entries can obtain a single or a double frame, such as @‘ or
by prefixing an entry with *[F-] or *[F=] and enclosing the portion of the
entry to be framed in braces. Normally, the frame will be very tight so that it

must be widened by prefixing with + or with ++. Round frames, such as @

and are obtained by specifying the shape as [0] . So the latter figure was
constructed as *++[o][F=]{B}. This way, the following automaton

start *)@D

\[\xymatrix{\txt{start}\ar[r]
& *++[o] [F1{1X\ar[r]
& *++[o] [F=]{2}\ar@(ur,dr)\ar@(ur,ul) [1]
NI

can be typeset as

The BTEX command \entrymodifiers={...} will make a certain entry style
the default, that can, of course be overridden for individual entries. Thus, after
\entrymodifiers={++[o] [F-1}, all following entries inside Xy-matrices would
be encircled.

4 Using LyX’s math editor

As an alternative to writing the xypic code, then transforming it into a math-
editing environment by marking it and applying Ctrl-m, or Ctrl-M, one may
construct and modify the whole xypic-diagram inside Iy X’s math editor. We
describe the editing steps for a figure just like the one above.

4.1 Caveat - how to enter braces

Recall that in IyX’s math-editor any pair of braces { and } that are to enclose
a macro-parameter must be entered by typing just \{ . The closing brace is
automatically supplied and in between a box into which to the parameter is
entered. In connection with Xy-diagrams, this applies in particular to arrow
modifications that are normally given in the form @{ ... } with the ellipsis
standing for the description of end, shaft and tip of the arrow. Inside the math-
editor, enter just @\{ and let LyX provide the closing brace and the box into
which to enter the description of the arrow.



Braces that are entered without the backslash \ will just appear as typed,
but cannot be used to receive a macro parameter. They are useful, for instance
to denote sets, e.g. {x\in X \mid x\notin x} will display as {z € X |z ¢ x}.

4.2 Setting up the matrix

With Ctrl-m or Ctrl-M open a formula environment and enter: \xymatrix.
This produces a 1x1- Xy=matrix. Add extra rows by typing Ctrl-Enter and add
columns by typing Alt-m c i.

At any time, further rows or columns can be entered or deleted using com-
mands available from Edit>Math, resp. their shortcuts, beginning with Alt-m c
for the column commands or Alt-m w for the row commands. !

4.3 Entering nodes, arrows and labels

Type the nodes into the correct positions of the matrix. If you move the cursor
out of the matrix, you should see a first rendering of the node layout. Next,
add the arrows at the nodes from where they should emanate by typing \ar [p],
where p can be any path made up from the characters u, d, 1, r. Make sure
that the path indeed leads to a node available within the matrix. Otherwise,
the figure will not display as the cursor leaves the editing area.

Next, label the arrows by attaching them as upper or lower indices to the
end of their path. As always, in IyX’s math editor, an underscore _ opens a box
for a lower index and a ~ followed by a space opens a box for an upper index.
You can enter any I#TEX-code as a label.

4.4 Modifying arrows

Finally, modify the appearance of the arrows by entering @-modifiers @{... },
Q<...>,Q(...,...) or @/.../. The above caveat applies to the first form only.
It must be entered as @\{ with the arrow description entered inside the LyX-
supplied box. If this box remains empty, you have specified an empty arrow.
This is a useful construction, too, as you will see in the next section.

The other modifiers, @<...>, @(...,...) and @Q/.../ are typed as shown
with the arrow description replacing the ellipsis. The code for bending arrows,
which in xypic is @/_measure/ or @/ “measure/ where measure is any valid
TrX-measure, should be entered as upper or lower index to the first slash / .
Make sure that the ending slash does not end up with the upper or lower index.

4.5 What if something goes wrong

When constructing a diagram, you should at times check it by just moving the
cursor out of the editing area to see whether instant preview can successfully
convert it into graphical output. If this does not happen, it may either be that
instant preview for some reason is not aware that it should modify retranslate
the graphics. Moving the cursor into the editing area and out again should wake
up instant preview.

1Note that in the keyboard shortcuts starting with M- the letter M stands for a “Meta’-key,
which in Windows translates to the Alt-key. Similarly in shortcuts listed as starting with C-,
the C stands for Ctrl.



A more serious reason could be a syntactical error in your input. If necessary,
redo the last editing steps, using Ctrl-z, or try to translate the LyX-file into
dvi using Ctrl-d or View>Dvi. There should be some error generated, which
hopefully gives you a hint as to the source of the mistake.

5 Hacks

Certain things do not work correctly inside IyX. The ones that we (used to)
miss most are the horizontal and vertical scaling of diagrams, and the correct
positioning of arrows. After some experimentation, we have found workarounds
that we are explaining here.

5.1 Horizontal and vertical scaling

It is often convenient to stretch the horizontal or vertical dimensions of a diagram
by using spacing commands for rows and/or columns. According to the Xy-
manual, for instance, \xymatrix@R=1pc{...} defines an Xy-matrix with row
spacing of 1 pica. Similarly, \xymatrix@C=...{...} allows to modify the space
between columns. Unfortunately, these commands do currently not work inside
LyX, as the @-character is interpreted by LyX as ending the Xy-matrix-macro.

Knowing that Xystores the values for row-spacing and column-spacing in the
variables \xymatrixrowsep@ and \xymatrixrowsep@, add the following macro
to the preamble (LayoutDocument>Preamble)

\makeatletter
\newcommand{\xyR} [1]1{%
\makeatletter
\xydef@\xymatrixrowsep@{#1}
\makeatother

} % end of \xyR

A macro \xyC can be defined correspondingly by replacing \xymatrixrowsep@
with \xymatrixcolsep@ Now, a figure can be scaled by entering \xyR{...}
into the Xy-matrix. Place the cursor inside the matrix, just before the first
entry. Then enter \xyR\{ or \xyC\{ or both. Dont’t forget the backslashes and
remember, that the closing brace is automatically supplied by LyX. Inside the
braces enter the dimensions. The default is 2pt. Here you see a diagram which
is squashed vertically and stretched horizontally with \xyR{9pc}\xyC{.5pc}:

A B
l horizontal stretch
C

5.2 Invisible arrows

Another Xy-feature not functioning in LyX is the correct positioning of labels
along the shaft of arrows. The code \ar[r]|(0.3)\varphi, for instance will
place the label ¢ not in the middle of the arrow, but rather at about 30% of
the way from its origin. The same ought to work with labels above or below

10



the arrow, e.g. \ar[r]~(0.3)\phi or \ar[r]_(0.3)\phi. Unfortunately, this
simple does not function in IyX.

Still, this feature is sometimes necessary, when the default position of the
label would otherwise clutter the picture, or even coincide with other items,
such as the intersection of the arrows in the figure below.

For strictly horizontal arrows, a workaround is easy: just pad the label itself
with enough spaces to make the visible part shift enough to the right or to the
left, as e.g. in \ar [r] "{\phi\ \ \ }. For vertical or diagonal arrows, this does
not work, so you might wish to use the following trick:

Produce an invisible second arrow, shorten (or prolong) it past its goal by
adding a decimal stretching ratio, e.g. (0.6) or (1.4) to its path. Attach the
label to this invisible arrow. In the above diagram, the downward pointing arrow
with its label was produced by \ar [dr] \ar@{}[dr(0.6)]"\varphi, where the
second arrow is the invisible one, reaching only 0.6 of the way. Hence the label
will appear at 0.3 of the way of the original visible arrow.

This workaround has two minor drawbacks: First, it does not work with
bending arrows. Secondly, prolonging an invisible arrow beyond the normal
dimension of the figure will invisibly extend the figure box, and thereby cause
too much vertical space between the figure and the preceding or the folling
paragraph.

Invisible arrows are an important tool, though, since they can, in principle,
be used to place information at any chosen place in a diagram. Above, for
instance, we have used an invisible arrow to carry the \vdots as label and at
the preceding picture we had used an invisible arrow to carry some text into the
center of the figure.
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